Zodiac FX and ONOS issues

  • 5 Replies
  • 1990 Views
*

bhandari

  • Newbie
  • *
  • 1
    • View Profile
Zodiac FX and ONOS issues
« on: March 10, 2017, 11:56:38 PM »
Hello,

I have been using ONOS Controller. However, it doesn't seem functioning well with Zodiac FX (Firmware Version : 0.72). I have problems in both OF 1.0 and OF 1.3.

1. With OF 1.0, ONOS controller seems to be adding the flow rules, however the packets don't meet the flow rules and are always redirected to controller. So, for every packet, the controller is pushing flow rules to the switch. Soon after, Controller shows Table Full message received from the switch in it's log. In the switch, initially the "show flows" command shows the flows installed and same rules are seen multiple times. When the controller receives "Flow Table Full", message, the switch doesn't show any flow rules (no flow rules are seen). However, if the rules are cleared, the switch accepts rules again from the controller but the same scenario repeats again and again.

2. With OF 1.3, the initial Hello,  Features and Config message exchange occurs. Then after, only the ECHO_REQUEST and ECHO_REQUEST reply messages are exchanged between the both. Controller doesn't show the connected device (switch). No further operation can be done.

To mention: the same controller and same applications I am using with Zodiac FX have been working fine in HP 3500 switch and Open vSwitch.

The Wireshark captures for both the cases are attached.

Could anybody suggest me, where the problem lies.

Thanks
Bhandari

*

Paul Zanna

  • Moderator
  • Sr. Member
  • *****
  • 367
    • View Profile
    • Northbound Networks
Re: Zodiac FX and ONOS issues
« Reply #1 on: March 11, 2017, 10:59:19 AM »
Hi Bhandari,

Thank you for taking the time to detail your findings and provide the captures. It has been a while since we have used ONOS but we'll definitely go back and take another look at what the current compatibility situation is.

Regards,
Paul

*

siriulx

  • Newbie
  • *
  • 1
    • View Profile
Re: Zodiac FX and ONOS issues
« Reply #2 on: March 19, 2017, 06:03:56 AM »
I have the same issue using Zodiac FX with the ONOS latest version. But if I use ONOS version below 1.6.0, everything will be good.

*

Paul Zanna

  • Moderator
  • Sr. Member
  • *****
  • 367
    • View Profile
    • Northbound Networks
Re: Zodiac FX and ONOS issues
« Reply #3 on: March 20, 2017, 09:00:41 AM »
Obviously something has changed in the current version to impact compatibility, it looks like a meters config request. The next update has meter functionality and therefore should respond to this request correctly and hopefully resolves the issue.

Regards,
Paul
« Last Edit: March 20, 2017, 09:03:38 AM by Paul Zanna »

*

jsoler

  • Newbie
  • *
  • 1
    • View Profile
Re: Zodiac FX and ONOS issues
« Reply #4 on: November 13, 2017, 09:16:14 PM »
Hi Paul, is there anything new about this? Has the issue been solved for the most recent FX boards to work with later versions of ONOS? Thanks :)

*

rrg123

  • Newbie
  • *
  • 2
    • View Profile
Re: Zodiac FX and ONOS issues
« Reply #5 on: December 20, 2017, 02:44:26 AM »
Bhandari,
I am trying to use ONOS and have it installed. I can ping the Zodiac FX port 4 but I can not find documentation on how to configure ONOS to connect to the switch. I have tried different port on the FX switch like
8181 (Rest API and GUI)
6653 (OpenFlow)
and
6633 that I saw on this forum.

Can you provide me a link or instructions to get the connection established?
Thank you in advance.