Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - kyleoneal

Pages: [1]
1
Zodiac FX Firmware / TLS Support
« on: December 13, 2018, 06:50:32 AM »
Are there any plans to support TLS?  I'd like to allow a cheap way for people to play with an ICS SDN controller like SELs 5056, but it only supports OF1.3 with TLS. 

2
Zodiac FX General / Re: Communication issue with Zodiac FX
« on: March 14, 2018, 02:03:54 AM »
Setup is as follows;

Two Zodiac FX switches. 
Z1 - p1-p2 are connected to raspberry pis.  P3 - Z2/P3. P4 connected to netgear switch.
Z2 - P3 - Z1/P3  P4 connected to netgear switch.

Z1 10.0.1.99/24
gateway 10.0.1.1
Controller 10.0.1.8

Z1 10.0.1.100/24
gateway 10.0.1.1
Controller 10.0.1.8

Pi1 - 10.0.1.44/24
Pi2 - 10.0.1.42/24

Controller is ONOS running on a Mac Mini which is also connected to netgear switch.

Problem 1; On the controller I can see both switches, but it does not recognize the z1-z2 connection on P3.  May be a controller thing, not sure.  Maybe I have the zodiacs misconfigured?  Anything I need to do to enable comms between them on P3?

Problem 2; I can't ping between the Pis.  I can disconnect them from the Zodiac and plug them into the netgear switch and I can ping them just fine.  All vlan config is the standard config that came on the switches.  Can't see the hosts on the ONOS controller either.


Any assistance would be appreciated. 

Kyle

All aforementioned problems were resolved by updating the firmware on the Zodiacs. 

3
Hi,

There is no MAC version of SAM-BA, you'll need to use Windows or Linux. You can also update the firmware via the Web UI from your MAC (Chrome browser recommended).

Regards,
Paul

OK, thank you for the answer.  If I understand the docs correctly, you can only update via browser after a certain firmware though, correct?  I am on firmware 0.58.

Kyle

4
Zodiac FX General / Communication issue with Zodiac FX
« on: March 13, 2018, 05:24:29 AM »
Setup is as follows;

Two Zodiac FX switches. 
Z1 - p1-p2 are connected to raspberry pis.  P3 - Z2/P3. P4 connected to netgear switch.
Z2 - P3 - Z1/P3  P4 connected to netgear switch.

Z1 10.0.1.99/24
gateway 10.0.1.1
Controller 10.0.1.8

Z1 10.0.1.100/24
gateway 10.0.1.1
Controller 10.0.1.8

Pi1 - 10.0.1.44/24
Pi2 - 10.0.1.42/24

Controller is ONOS running on a Mac Mini which is also connected to netgear switch.

Problem 1; On the controller I can see both switches, but it does not recognize the z1-z2 connection on P3.  May be a controller thing, not sure.  Maybe I have the zodiacs misconfigured?  Anything I need to do to enable comms between them on P3?

Problem 2; I can't ping between the Pis.  I can disconnect them from the Zodiac and plug them into the netgear switch and I can ping them just fine.  All vlan config is the standard config that came on the switches.  Can't see the hosts on the ONOS controller either.


Any assistance would be appreciated. 

Kyle

5
I've tried following the instructions I have found, to no avail.  Can't get the SAM-BA software to install correctly.  Just get the error "cannot execute the binary file".


6
I just received my FX boards and I have not been able to find any tutorials on getting these to connect to ONOS.
Can you point me in the correct direction.

For now I will try to install the other controllers.

Thank you in advance.
rrg

#1 Good luck.  Tons of stuff out there for mininet and ONOS, but little on using it on a piece of hardware.
#2 I have had a little success here, though not much.  I installed ONOS from scratch using the Wiki instructions, on a Mac Mini and have the GUI running locally.  From there I have 2 Zodiacs connected to a dumb switch and both have the controller's IP address.  The controller can see them both, but that is about as far as I have gotten so far.   If you have any specific questions I'll try to help.

Kyle

Pages: [1]